󰅡收起

老薛网络

专注区域互联网运营、产品、发展、市场合作

28
五月

linux下无法使用DOMDocument类

作者: alizee
分类: linux
发布时间: 2017-05-28 23:05

linux下php默认不开启GD库,也不支持DOMDocument类,即 DOM扩展。
没有GD库的话,验证码显示不了,
没有xml.so的话,php操作不了xml,好端端的程序就运行不起来了。

先查看是否按照GD库和DOM扩展。

rpm -qa |grep php-gd
rpm -qa |grep php-xml
  • 1
  • 2

如果没有装,就无输出。安装如下:

yum install php-gd
yum install php-xml

// 如果是php5.6等版本的话,可以尝试下面的安装
yum install php56w-xml
  • 1
  • 2
  • 3
  • 4
  • 5

如果 ubuntu,debian系的,设置好源后apt-get install 文件名,再service httpd restart 重启apache 即可!

如果是自己编译的php,那就执行上面的之后可能还要手动添加扩展
find / -name php.ini 找到php.ini路径
vim 路径,
看看extension_dir=什么
记下扩展文件夹路径
find / -name dom.so 等,分别找到
dom.so xmlwriter.so xmlreader.so xsl.so gd.so
移动到php.ini指定的扩展文件夹里vim php.ini路径,
加上

extension=dom.so
extension=gd.so
  • 1
  • 2

等等上面5个so重启apache即可。

没有yum源的话可以自己找一个,运气好能找到,找不到的话就在这里搜rpm装。这里的rpm解决了令人头痛的依赖。很不错。

http://rpmfind.remotelan.net/linux/RPM/index.html

如果出现 Header V3 DSA signature_ NOKEY, key ID
error: Header V3 DSA signature: BAD, key ID
之类的错误,使用强制安装即可

󰁠

本文出自 老薛网络 ,转载时请注明出处及相应链接。

本文永久链接: http://der.cc/archives/103

发表评论

电子邮件地址不会被公开。 必填项已用*标注